nettechonline

Tech Supp - The Final Frontier!

  • Increase font size
  • Default font size
  • Decrease font size
Home Cisco CCNA
CCNA

Home Lab Archive

E-mail Print PDF

Set Up Your Home Router Lab! Part 1 - Archive


by Erik Westgard and Michelle Truman 

January 2000 
<webadmin - this is a very old article I found however the premise is still applicable for todays home lab. The reason I posted this was I was hoping this would give some insight into how to setup a serial to serial connection in a home lab. If you look it is fun to see that we can now purchase a 2600 router on eBay for about $20.00  - The article was published in January 2000 and at that time the cost was considerably higher than $20.00! >

To really learn routing and demonstrate the full power of IOS and the operation of routing protocols on a simulated wide area network (WAN), you'll need at least two routers connected together. Many production Cisco installations around the world use routers as the building blocks of their wide area networks. Common configurations such as a hub and spoke configuration include a headquarters and one or more branch offices, which is worthwhile to simulate on your lab. Most Cisco routers are equipped with one or more LAN ports and serial connections. Normally, the serial ports go to DSU/CSU (Data and Channel Service Units), which in turn connect service provider wan links.

 For the purposes of a home lab, you can connect serial interfaces with what is known as a "back to back cable assembly." You can connect Ethernet interfaces via a hub or crossover cable, but most of the available router models have only one Ethernet interface, and you don't get to work with serial interfaces, which you'll find in the exam requirements.

To connect serial interfaces, you need a DCE cable on one router and a DTE on another. The most common serial router cables are equipped with V.35 connectors -- female for DCE, and male for DTE. The routers themselves have one of two kinds of female jacks for serial interfaces -- a mini-DB60 on the new models and a larger, DB50 jack on the older models. Make certain you have the right types of cables and that you're careful with the pins on these cables, as they're delicate. (It's actually possible to connect the DB60 connectors upside down!) Most router cables aren't found in local computer stores, so you'll need to buy the official Cisco proprietary cables at around $100 each new. The used price is about half that.

 One important note on connecting routers via back-to-back cables: At least one router must support clocking (DCE) -- the IOS "clockrate" command. The 2500, 3104, and 4000 serial interfaces do, but some older 3000 and IGS models don't. Let's look at some of the new router models that can be used in a home certification lab:

 

  • 600, 700, and 800 Series -- These routers fall into the category of SOHO (Small Office-Home Office) and should only be used to augment a home lab. They can be useful for practicing dial technologies such as ISDN and DSL, and they're inexpensive. Unfortunately, SOHO routers run a limited IOS release, (the 700s are non-IOS) and most models aren't suitable for back-to-back connection.

     

  • 1000, 1600 Series -- These run IOS; you can get serial/Ethernet models; but you won't find on these several advanced routing protocols and legacy desktop protocols you might find on an exam.

     

  • 1700 Series -- This new series has a lot of available security and encryption extensions to IOS, but are limited on routing and desktop protocol support.

     

  • 2500 Series -- These are the first of the "enterprise" routers in the current Cisco line. You can run the latest full IOS on these, including virtually all the available features and routing protocols. They're around $1,800 new depending on the model you select and can be upgraded with up to16M of flash memory and 16M or 18M of RAM. The most popular certification box, the 2501, supports two serial ports (DB60), Ethernet, and DCE clocking. Some of the latest security features on the IOS firewall are starting to require a faster processor than the 68030 in the 2500.

     

  • 2600, 3600 and up -- Modular routers intended as an eventual replacement to the 2500 and 4000 series routers, they may be overkill for a certification lab, but you get a lot of nice features: full IOS support, quiet fans, lots of memory expansion, and fast processors.

Used Routers

Since you're looking at the need to support the full IOS protocol and feature range for the exams, one good choice is to pick up used enterprise-grade routers. Cisco hardware is rock-solid. So if you buy a unit that's working, the fact that a system isn't supported by Cisco any more should not be a major worry. (When Cisco says a router has reached "end of support," you can't buy a service contract or get factory-supplied support or parts any more.)

Some of these models aren't Y2K certified, although this has much to do with the IOS version you're running. Cisco routers have real time clocks, but these don't seem to be critical to the operation of the routers.

Watch for "Cisco Pro"/"White Box" models of many routers advertised. These were the result of a temporary experiment by Cisco in selling software feature-limited routers via resellers and dealers. This experiment has ended, and you can upgrade these routers in software and firmware to look like a normal router of the same model. Cisco Pro models sell for less in the used market.

Token ring models are available, and tend to be cheaper in the used market. The serial ports work the same; and you can find back-to-back cables, so you could connect servers to the token ring interface without an external MAU hub unit.

Tip: If you are planning to advance along the CCIE certification track, you'll want to have access to at least one token ring router. There you'll encounter emphasis on IBM protocols such as SNA and ring technologies such as Source route bridging and DLSW+.

The used market takes several forms. eBay.com and other auction sites bring together buyers and sellers. At any given moment, eBay usually has 400 or so Cisco listings, many labeled with "perfect for CCNA." (Be a bit careful when you buy this way that you truly know what you're getting.) Cisco resellers are another source -- some will work with home lab customers, though most seem to prefer high-volume commercial customers. You can also buy routers from ads in newsgroups, such as the ISP equipment list.

We've seen a demand for used Cisco routers pick up in the last year, due to certification testing needs and because of a Cisco trade-in program that's on-going. Series 3000s are desirable for labs, but rare in the used market; they can be worth a lot in trade on new Cisco routers.

Memory for upgrading routers is widely available. You can buy actual Cisco-boxed and branded upgrades for many models, but these can be costly. Dealers will sell "Cisco Approved" memory for less, and you can find various types of generic memory chips for even less, such as on the auction sites. Cisco allows the use of certain other brands of approved memory even under their service contracts. Each model has complicated memory-related upgrade rules, so read the CCO memory upgrade articles carefully. You usually need a bare minimum of 4M of RAM (used for buffers and table storage) and 4M of flash (used to store IOS for booting) to run a Y2K-compliant (and exam-friendly) 11.x level of IOS.

Tip: Remember that boot ROM upgrades for out of support older routers aren't available any more.

 

Used Models

  • 2500 series, especially the 2501. These are the most popular certification routers and are fully supported by Cisco. Used prices start around $800 for Ethernet models. You can buy a SmartNet hardware/software contract on these for around $280 annually and get free upgraded boot ROMs, access to the "customer" sections of the Cisco Web site (including updated IOS downloads), access to the Cisco Technical Assistance Center, and hardware repair. Make sure you get a "console cable kit" for a 2500 -- these have an RJ45 serial console connector than requires a reversed RJ45 cable and a special series of connectors to adapt to the RS232 port on your PC or terminal as a console. You'll need RJ45-to-AUI Ethernet transceivers on the 2500, 3000, and IGS models to adapt to newer 10BaseT wiring and hubs. These are around $30 new or used.

     

  • 3000 Series. These models preceded the 2500 series and, as far as IOS is concerned, look identical. They're no longer supported; but several models can be upgraded to 8M of flash, and 16M of RAM. The most popular is the 3102, ($300), which supports an Ethernet and serial port (no DCE clocking, so you must connect to a router with clocking). It uses standard Cisco flash memory (up to 8M) and supports old PC type 30-pin SIMM memory up to 16M. The 3104 ($500) is nice if you can find one with one or two serial ports (plus DCE clocking), one Ethernet port, plus a bonus ISDN BRI. The 3104 uses modern 2500-type RAM and flash memory. Several token ring models are available, but read up on these before buying them to make sure you can upgrade them. All 3000s use the old-style 50-pin serial cables and have AUI Ethernet connectors. You can use a short AUI cable or just remove the mounting studs near the Ethernet jack to fit the transceiver on these models.

     

  • IGS Series. These come in one Ethernet/one serial models (no DCE) called the IGS/R, a dual Ethernet model (IGS/L), and a token ring model (1S/1TR) called the IGS/TR. The IOS (usually an older 8.x or 9.1 release) comes on eight ROM chips (no flash), and IOS upgrades aren't available from Cisco any more (though rarely you can find them used on eBay). These are older, cost around $100 on auction sites, and have noisy fans that sound like vacuum cleaners. netbooting on most routers lets you run a reasonably recent (full-featured) version of IOS in RAM. (See "netbooting" later in this article.) IGS routers use the same cabling for the most part as the 3000s.

     

  • 2000 Series. These are rare, cost $120, and are like an IGS/R that was designed to be upgradeable to a 3000. The upgrade kits are no longer available.

     

  • AGS Series. These were formerly top-of-the-line Cisco routers. You can get many interfaces and run a reasonably recent IOS on these. They're big, power-hungry, hot and noisy, and have exotic serial connectors that are hard to find cables for. They sell for around $500 on eBay.

     

  • Older 4000 models. The 4000s are a family of medium-sized modular routers with three interface bays. You can plug in a combination of Ethernet, serial ports and other interfaces. New 4500 and 4700 models are still being sold, and the older models, such as the "classic" 4000 can be bought used (chassis only) for around $500. Interface cards, "blades" as they're sometimes called, are about $500 each. The older 4000s start at 4M of flash (usually enough, but hard to upgrade via a costly kit) and can be easily upgraded to 16M of RAM, which will run the latest IOS (some protocol-rich versions may require more flash). You can use a 4000 to build a really nice core router with dual or quad serial cards and an Ethernet card.
Our advice? We'd get a 2501 (a Pro model if you want to save a little and aren't worried about resale) along with a SmartNet contract to get CCO access and the ROM and IOS software upgrades you may need. We'd bring it up to 8M of flash, and at least 6M of RAM. For your second router, another 2501 or a 4000 would be ideal, or, for those on a budget, a 3102. The cheapest possible lab would be a 3104/3102 or 3104/IGS combination, but you wouldn't be able to buy a software or hardware contract for these.

In Part Two, we'll cover setting up your lab.

Last Updated on Saturday, 22 October 2011 05:15
 

Home Lab Archive - Part 2

E-mail Print PDF

Set Up Your Home Router Lab! Part 2 


by Erik Westgard and Michelle Truman 

March 2000 

Resources You Need
Various CCNA exam textbooks have information on cabling and introductory router setup. To supplement that, we use the Cisco Web site at http://cio.cisco.com, the Cisco documentation CD, or one of several router configuration reference books for basic hardware information. Two books we have found useful includeIntroduction to Cisco Router Configuration by Laura Chappell and Cisco Router Configuration by Allan Leinwand, Bruce Pinsky, and Mark Culpepper. Be sure to read reviews and ask around before you buy to get good quality study and reference material. Some of the online book-buying sites even support book rating systems.

For direct connections there are two serial encapsulation options: PPP and HDLC. It's possible to buy a single "back to back" serial cable with one DCE and one DTE end, or you may wish to buy both a DCE and DTE cable and connect them back to back. See Part 1 of our series for a rundown on cabling.

Tip: Note that using a router as a frame relay switch means you have devoted the serial interfaces to that purpose, so it's good to have four routers in that case. We'll devote a future article to building your own frame relay switch for advanced lab exercises. In Figure 1 there are two networks: Router B to A and Router A to C.

 


 


Figure 1. Back-to-back serial connections using encapsulation PPP or HDLC.

In Figure 2 there are also two networks represented from Router B to Router A and Router A to Router C. Note that Router A must tell router C how to reach Router B. This requires a routing protocol or static routes to be inserted on router A.


Figure 2. Back-to-back LAN connections, which can be Ethernet, using a hub or a cross-over cable, or token ring.

In Figure 3 we use Router A as a frame relay switch. If router A has only 2 serial ports, we can only use it to build a PVC (Permanent Virtual Circuit) from router B to router C. This means we can create only a single routed connection and makes it difficult to practice routing protocols. While it is possible to use subinterfaces on each router and create multiple PVC's between router B and C, this is still a directly connected network and does not give much practice with routing. If you are going to use a frame relay switch it is best to get something like a Cisco 4000 with 4 serial interfaces for multiple connections or to stick with back to back cabling and other layer 2 encapsulations.


Figure 3. Router A acts as a Frame Relay switch. Router B connects to Router C via one PVC, which is also one network.

Along with a target configuration, you should do a lab IP address plan. Additional planning could include IPX addresses, frame relay DLCIs, AppleTalk cable ranges, or Decnet node numbers and all layer 2 node and layer 3 network layer addresses you'll need for your lab. We suggest using RFC1918 private addresses, just to save yourself grief if you were to connect your network to the Internet or a production customer network. These private addresses aren't routable on the Internet, so they provide some measure of protection.

 

IP subnetting-the practice of dividing IP network blocks into smaller subnets-is an extremely important skill when attempting any level of Cisco certification. It's also critical to get some practice with different ranges of addresses, so you can build a comfort level in working with classical A, B, and C addresses as well as the concept of CIDR (classless inter-domain routing). The non-Internet routable addresses available for you to use are as follows:

Net block range Pre-CIDR class designation CIDR block
10.0.0.0 - 10.255.255.255 (1 Class A Network) /8
172.16.0.0 - 172.31.255.255 (16 contiguous Class B networks) /12
192.168.0.0 - 192.168.255.255 (256 contiguous Class C networks) /16

 

Consider using a couple of different ranges to get some practice with different net block sizes. You may want to use several /24s from the 192.168.0.0 range for your serial interfaces. You could use the 10.0.0.0 network for all of your LAN addresses and use 172.16.0.0 networks for loopback addresses and other miscellaneous tasks.

Resources
To read more about the concept of CIDR and classless addressing check out the following references:
  • For coverage of CIDR, visit:http://www.ietf.org/rfc/rfc1519.txt

  • For private addressing, visithttp://www.ietf.org/rfc/rfc1918.txt
  •  

    One of the easiest beginner pitfalls is to get the subnet masks wrong in a lab. If you settle on using Class A 10.0.0.0 network subnetted into /24 blocks, be sure you're consistent with the masks for every device on a particular network. One of us (Erik, to be specific!) can remember lots of grief from setting up a /16 mask on the TFTP server PC, and /24 masks on the router interfaces. It's possible to use differently sized masks for the same major network on different physical networks. But for beginners, just play it safe and keep all masks the same.

    You'll need console devices for direct access to the router interface. A PC makes a fine console, and even an older 486 machine or laptop can handle this job. The 2501 console kits come with a set of adapters, but I use the DB9, which fits the standard DB9 PC serial port that was first introduced with IBM PC/AT. Most of the other routers you may have in a lab use a DB25 console connection; but the little DB9 to RS232 adapter cables sold in any computer store work fine here. You can, of course, use straight through DB25 cables to the DB25 ports. Set your PC communications software (the standard terminal emulator feature included with Microsoft Windows works fine) to 9600 bps, which is the default on a Cisco router console interface, unless it's been changed in the router boot register.

    While setting up your console machine, you might want to make sure it has a TCP/IP stack and LAN card. You can then use that machine as your TFTP server. CCO has a free downloadable TFTP package (the 1.3M file TFTPServer1-1-980730.exe located at http://www.cisco.com/pcgi-bin/tablebuild.pl/tftpM/), and there are some other freeware versions. This will allow you to store IOS loads, and router configuration files on the PC hard disk. You can connect to the router via a 10BaseT crossover cable or a hub. One hint: If you're mixing older 10BaseT routers, and newer 100M PC LAN cards, make sure you have an autosensing hub; some 10/100 non-autosensing hubs won't translate the LAN adapter speeds. One last note: On the 4000, the default is to power the AUI port, not the 10BaseT port.

    On the subject of cabling, we suggest using only new 10BaseT cables. One of us (Erik, again!) had some old, used eight-wire telephone cables, with the correct RJ45 jacks, which seemed to work. These weren't rated for LAN speeds, and led me to suspect my 3104's Ethernet port. After an embarrassing trip back to the dealer for a "no trouble found" call, I tossed these out and bought new cables. If you look in the right places, these are around $5. There's a part of the spec for 10BaseT that suggests cables should be at least eight feet long.

    You may find your used router arrives at your door with a password set. Fortunately, if you search on CCO or even the comp.dcom.Cisco archives on deja.com, you can find the directions for "cracking" passwords. You're actually entering the break key from the console during boot and telling the router to ignore the configuration file, which has the passwords. It's most helpful to learn about the different settings of the boot register and to try booting the router from the subset IOS (usually) stored in ROM, vs. flash. Netbooting (loading IOS off of a TFTP server) is also mandatory if you have a really old router that needs to run a newer IOS in RAM or are doing any memory or IOS upgrades. It's also possible (although slow and tricky) to load IOS via the console or AUX ports via Xmodem if you're using Cisco 2600 or 3600 series routers.

    On the subject of IOS, used routers will normally have an older IOS loaded, like 9.1 or 10.1. If you have a SmartNet contract on a supported router, you can go right to the software center on CCO and download the version you need. Remember: You only get what you paid for in terms of feature sets. If your router came licensed for Enterprise, you can download a newer version of Enterprise from CCO. If it only came with IP and you want Enterprise (or IP Plus or Firewall), you need to purchase the appropriate upgrade package from Cisco or a dealer. The 2500s have feature packages you can buy that have a CD included with the IOS and a software loader. The whole licensing issue on out-of-support routers is tricky. On his 3000s Erik's running a version of 11.1 IP that was provided by Cisco's Y2K desk, since they say these models are Y2K-compliant on that release as a minimum.

    A brand new router, or one where a configuration file is invalid or unavailable, will prompt you to enter setup mode. This is a dialog-driven way to assign your router a name and some passwords and to get the basic interfaces up and running. This is where you should follow your addressing plan (and watch out for those mask issues). You can also enable some of the routing protocols from the setup dialog. If you choose to perform configurations manually (a good idea for certification practice anyway) just say, "no," when asked to save the configurations from setup mode.

    Ping is your friend here. You can ping the routers from each other and from your TFTP server at the MS-DOS prompt. The Cisco Discovery Protocol -- a media and protocol independent way for Cisco routers to find each other on any network -- is available on newer versions of IOS. If your IP or IPX addressing isn't right but the routers are cabled properly, (and you have the clocking set properly on the serial ports), CDP will see them. Another valuable networking tool available to you from the router prompt is the traceroute command. You can use traceroute to verify the path taken from the host you're on to any given destination.

    Once you have two or more routers communicating, you'll want to enable some form of IP routing. The old, standard routing protocol and perhaps the simplest to use is to enable Router RIP (Routing Information Protocol). You merely enable the protocol and type in the network you wish to route, and RIP routes will begin to flow. Your directly connected interfaces won't show up in the RIP table though. You may wish to use loopback interfaces-virtual IP networks-on each router to simulate routing traffic.

    Other routing protocols you should play with are OSPF, IGRP, and EIGRP. The latter two are proprietary to Cisco, while OSPF and RIP are RFC-developed protocols. Each routing protocol has different advantages and disadvantages. A challenge for you is to develop a good understanding of how a distance vector routing protocol (RIP) differs from a Link State Protocol, which differs from a hybrid (EIGRP), and finally a path vector routing protocol (BGP).

    This should be enough to keep you very busy until our next article, in which we'll discuss the details of building a frame relay switch, distributing between two different routing protocols, and dealing with "routed" protocols such as IPX, AppleTalk, and SNA.

     

    Home Lab Archive - Part 3

    E-mail Print PDF

    Set Up Your Home Router Lab! Part 3 

    by Erik Westgard and Michelle Truman 

    September 2000 

    While you should absolutely run the menu-driven setup program on your routers and get IP addresses on the interfaces assigned and some basic connectivity going, you'll need to develop, enter, and debug some configurations from scratch. While we can't reveal what exactly is on the exam, we can say that the test is very cleverly designed to separate those who have worked with routers or simulators in a lab or classroom setting and those who have only read the books. Hands-on time rules.

    For the labs we'll assume you have the classic "three 2501s" rack or equivalent. One router is picked as the core (with multiple interfaces), and two are designated as edge routers. One reading of Cisco's Y2K IOS policy is that you can run at a minimum 11.0 IP IOS on most of their Y2K-compliant routers, no matter what their origin, so this will get you in the ballpark with a reasonably current command line and structure.

    Lab One: Static Routes

    In this lab, you explicitly tell each router how to get packets from one router to the next. Nothing is assumed, and nothing is left to chance. A person sitting at our LeftWks PC who needs to check files on the RightWks system can ping that system to make sure it's available and then log in to transfer files.


    For the first lab we can start with a router that has been "write erased" with no configuration at all loaded. Many times when you buy a router, it will arrive that way. We need to add IP addresses to three interfaces on the HQ router. We're using the Ethernet to get to a server in headquarters, and in our lab situation, that interface will support a laptop PC that we're using with the Microsoft Windows terminal program as our console as well as a TFTP server to let us load Cisco IOS as needed and to save configurations.
    You can power up the router and start with the menu-driven setup program, which can take you almost but not quite to a working network. You have to go into configuration mode to set the clock rate on the HQ router serial ports.

    HQ#config t 
    Enter configuration commands, one per line. End with CNTL/Z.
    HQ(config)#ip route 10.10.90.0 255.255.255.0 10.10.20.8
    Router Routes HQ(config)#ip route 10.10.40.0 255.255.255.0 10.10.60.8
    HQ(config)#int ser0
    HQ(config-if)#clock rate 64000
    HQ(config-if)#int ser1
    HQ(config-if)#clock rate 64000


    Here's the config for HQ:

    Current configuration:

    !
    version 11.1
    service udp-small-servers
    service tcp-small-servers
    !
    hostname HQ
    !
    enable secret 5 $1$m5lS$PXPz49nqonQX6Ir4QnjMO/
    enable password router
    !
    !
    interface Ethernet0
    ip address 10.10.50.1 255.255.255.0
    no mop enabled
    !
    interface Serial0
    ip address 10.10.20.1 255.255.255.0
    no fair-queue
    clockrate 64000
    !
    interface Serial1
    ip address 10.10.60.1 255.255.255.0
    clockrate 64000
    !
    interface BRI0
    no ip address
    shutdown
    !
    no ip classless
    ip route 10.10.40.0 255.255.255.0 10.10.60.8
    ip route 10.10.90.0 255.255.255.0 10.10.20.8
    logging buffered
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    end


    For the Branch routers, you have to set up a static route to reach the other branch Ethernet, the HQ LAN, and the serial interface for the other branch router.

    branch1(config)#ip route 10.10.40.0 255.255.255.0 10.10.20.1 
    branch1(config)#ip route 10.10.50.0 255.255.255.0 10.10.20.1
    branch1(config)#ip route 10.10.60.0 255.255.255.0 10.10.20.1

    This tells the Branch1 router how to find these subnets, which are one hop away.

    Here's the config:

    Current configuration:
    !
    version 11.1
    service udp-small-servers
    service tcp-small-servers
    !
    hostname branch1
    !
    enable secret 5 $1$6hl9$aT0D4mIeDedNThp8E41F21
    enable password router
    !
    interface Ethernet0
    ip address 10.10.90.1 255.255.255.0
    !
    interface Serial0
    ip address 10.10.20.8 255.255.255.0
    !
    no ip classless
    ip route 10.10.40.0 255.255.255.0 10.10.20.1
    ip route 10.10.50.0 255.255.255.0 10.10.20.1
    ip route 10.10.60.0 255.255.255.0 10.10.20.1
    logging buffered
    !
    !
    line con 0
    line aux 0
    transport input all
    line vty 0 4
    password cisco
    login
    !
    end

    On Branch 2, we need to set up static routes to see the Ethernet behind the Branch1 router and the Ethernet at HQ, and the serial to Branch1 if we ever wanted to access that router.

    branch2(config)#ip route 10.10.20.0 255.255.255.0 10.10.60.1
    branch2(config)#ip route 10.10.50.0 255.255.255.0 10.10.60.1
    branch2(config)#ip route 10.10.90.0 255.255.255.0 10.10.60.1
    The configuration for Branch2 is in the same format as Branch 1:

    Current configuration:
    !
    version 11.1
    service udp-small-servers
    service tcp-small-servers
    !
    hostname Branch2
    !
    enable secret 5 $1$ZYeO$ph0MqSEF60pRdwtKJfG0d1
    enable password router
    !
    !
    interface Ethernet0
    ip address 10.10.40.1 255.255.255.0
    no mop enabled
    !
    interface Serial0
    ip address 10.10.60.8 255.255.255.0
    !
    no ip classless
    ip route 10.10.20.0 255.255.255.0 10.10.60.1
    ip route 10.10.50.0 255.255.255.0 10.10.60.1
    ip route 10.10.90.0 255.255.255.0 10.10.60.1
    logging buffered
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    end

    You can test the static routes by pinging the workstation on Branch2's Ethernet from Branch 1. Here's what we see about our network from Branch2:

    Branch2#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
    U - per-user static route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 5 subnets
    S 10.10.20.0 [1/0] via 10.10.60.1
    C 10.10.40.0 is directly connected, Ethernet0
    S 10.10.50.0 [1/0] via 10.10.60.1
    C 10.10.60.0 is directly connected, Serial0
    S 10.10.90.0 [1/0] via 10.10.60.1
  • Lab Two: RIP

    As you could see in the fist lab, typing in all the routes manually is a bit of a nuisance, and trying to do this on a large or change-prone network could be a lot of work. You can use RIP to let the routers build and maintain dynamic routes.
    If you're doing these labs sequentially, you'll first need to log into each router and remove the static routes from global configuration mode. Here's how to do this for the HQ router:

    HQ(config)#no ip route 10.10.90.0 255.255.255.0 10.10.20.8
    HQ(config)#no ip route 10.10.40.0 255.255.255.0 10.10.60.8
    Do a wr t from the privileged mode # prompt to make certain these routes are removed.
    Now for each router, go into global configuration mode, turn on RIP, and advertise the relevant local interfaces. For HQ, this would be:

    HQ(config)#router rip
    HQ(config-router)# network 10.0.0.0
    If you do the same on both branch routers, then you can reach all the endpoints without manual intervention. You can run show IP Route to verify the operation and, of course, use Ping.
    Here's the route situation from Branch2 after we've removed the static routes and enabled RIP:

    Branch2#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1-IS-IS level-1, L2 - IS-IS level-2,*-candidate default
    U - per-user static route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 5 subnets
    R 10.10.20.0 [120/1] via 10.10.60.1, 00:00:15, Serial0
    C 10.10.40.0 is directly connected, Ethernet0
    R 10.10.50.0 [120/1] via 10.10.60.1, 00:00:15, Serial0
    C 10.10.60.0 is directly connected, Serial0
    R 10.10.90.0 [120/2] via 10.10.60.1, 00:00:15, Serial0
    Running ping, we can reach all of the networks from any other endpoint.

  • Lab Three: IGRP

    In Lammle's new CCNA book, he develops an IGRP lab by simply adding IGRP to the existing RIP configuration. This saves time and illustrates several points about IGRP.
    From global config mode, decide on an Autonomous System number (like 6), and enter that on each router, as we're doing on Branch2 below:

    Branch2(config)# router igrp 6
    Branch2(config-router)# network 10.10.0.0
    After enabling IGRP on all three routers, we can look at the IP routes from Branch2:

    Branch2#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
    U - per-user static route

    Gateway of last resort is not set

    	10.0.0.0/24 is subnetted, 5 subnets
    I 10.10.20.0 [100/10476] via 10.10.60.1, 00:00:26, Serial0
    C 10.10.40.0 is directly connected, Ethernet0
    I 10.10.50.0 [100/8576] via 10.10.60.1, 00:00:26, Serial0
    C 10.10.60.0 is directly connected, Serial0
    I 10.10.90.0 [100/10576] via 10.10.60.1, 00:00:26, Serial0

     

    Note that even though RIP is still running, the IGRP routes have a lower administrative distance than RIP and are preferred. For those planning to take the CCNA, make sure you have the complete administrative distance table in your notes, if not memorized.

  • Last Updated on Saturday, 22 October 2011 05:15
     


    Page 2 of 2