nettechonline

Tech Supp - The Final Frontier!

  • Increase font size
  • Default font size
  • Decrease font size
Home Cisco CCNA Home Lab Archive - Part 3

Home Lab Archive - Part 3

E-mail Print PDF

Set Up Your Home Router Lab! Part 3 

by Erik Westgard and Michelle Truman 

September 2000 

While you should absolutely run the menu-driven setup program on your routers and get IP addresses on the interfaces assigned and some basic connectivity going, you'll need to develop, enter, and debug some configurations from scratch. While we can't reveal what exactly is on the exam, we can say that the test is very cleverly designed to separate those who have worked with routers or simulators in a lab or classroom setting and those who have only read the books. Hands-on time rules.

For the labs we'll assume you have the classic "three 2501s" rack or equivalent. One router is picked as the core (with multiple interfaces), and two are designated as edge routers. One reading of Cisco's Y2K IOS policy is that you can run at a minimum 11.0 IP IOS on most of their Y2K-compliant routers, no matter what their origin, so this will get you in the ballpark with a reasonably current command line and structure.

Lab One: Static Routes

In this lab, you explicitly tell each router how to get packets from one router to the next. Nothing is assumed, and nothing is left to chance. A person sitting at our LeftWks PC who needs to check files on the RightWks system can ping that system to make sure it's available and then log in to transfer files.


For the first lab we can start with a router that has been "write erased" with no configuration at all loaded. Many times when you buy a router, it will arrive that way. We need to add IP addresses to three interfaces on the HQ router. We're using the Ethernet to get to a server in headquarters, and in our lab situation, that interface will support a laptop PC that we're using with the Microsoft Windows terminal program as our console as well as a TFTP server to let us load Cisco IOS as needed and to save configurations.
You can power up the router and start with the menu-driven setup program, which can take you almost but not quite to a working network. You have to go into configuration mode to set the clock rate on the HQ router serial ports.

HQ#config t 
Enter configuration commands, one per line. End with CNTL/Z.
HQ(config)#ip route 10.10.90.0 255.255.255.0 10.10.20.8
Router Routes HQ(config)#ip route 10.10.40.0 255.255.255.0 10.10.60.8
HQ(config)#int ser0
HQ(config-if)#clock rate 64000
HQ(config-if)#int ser1
HQ(config-if)#clock rate 64000


Here's the config for HQ:

Current configuration:

!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname HQ
!
enable secret 5 $1$m5lS$PXPz49nqonQX6Ir4QnjMO/
enable password router
!
!
interface Ethernet0
ip address 10.10.50.1 255.255.255.0
no mop enabled
!
interface Serial0
ip address 10.10.20.1 255.255.255.0
no fair-queue
clockrate 64000
!
interface Serial1
ip address 10.10.60.1 255.255.255.0
clockrate 64000
!
interface BRI0
no ip address
shutdown
!
no ip classless
ip route 10.10.40.0 255.255.255.0 10.10.60.8
ip route 10.10.90.0 255.255.255.0 10.10.20.8
logging buffered
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end


For the Branch routers, you have to set up a static route to reach the other branch Ethernet, the HQ LAN, and the serial interface for the other branch router.

branch1(config)#ip route 10.10.40.0 255.255.255.0 10.10.20.1 
branch1(config)#ip route 10.10.50.0 255.255.255.0 10.10.20.1
branch1(config)#ip route 10.10.60.0 255.255.255.0 10.10.20.1

This tells the Branch1 router how to find these subnets, which are one hop away.

Here's the config:

Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname branch1
!
enable secret 5 $1$6hl9$aT0D4mIeDedNThp8E41F21
enable password router
!
interface Ethernet0
ip address 10.10.90.1 255.255.255.0
!
interface Serial0
ip address 10.10.20.8 255.255.255.0
!
no ip classless
ip route 10.10.40.0 255.255.255.0 10.10.20.1
ip route 10.10.50.0 255.255.255.0 10.10.20.1
ip route 10.10.60.0 255.255.255.0 10.10.20.1
logging buffered
!
!
line con 0
line aux 0
transport input all
line vty 0 4
password cisco
login
!
end

On Branch 2, we need to set up static routes to see the Ethernet behind the Branch1 router and the Ethernet at HQ, and the serial to Branch1 if we ever wanted to access that router.

branch2(config)#ip route 10.10.20.0 255.255.255.0 10.10.60.1
branch2(config)#ip route 10.10.50.0 255.255.255.0 10.10.60.1
branch2(config)#ip route 10.10.90.0 255.255.255.0 10.10.60.1
The configuration for Branch2 is in the same format as Branch 1:

Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Branch2
!
enable secret 5 $1$ZYeO$ph0MqSEF60pRdwtKJfG0d1
enable password router
!
!
interface Ethernet0
ip address 10.10.40.1 255.255.255.0
no mop enabled
!
interface Serial0
ip address 10.10.60.8 255.255.255.0
!
no ip classless
ip route 10.10.20.0 255.255.255.0 10.10.60.1
ip route 10.10.50.0 255.255.255.0 10.10.60.1
ip route 10.10.90.0 255.255.255.0 10.10.60.1
logging buffered
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end

You can test the static routes by pinging the workstation on Branch2's Ethernet from Branch 1. Here's what we see about our network from Branch2:

Branch2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 5 subnets
S 10.10.20.0 [1/0] via 10.10.60.1
C 10.10.40.0 is directly connected, Ethernet0
S 10.10.50.0 [1/0] via 10.10.60.1
C 10.10.60.0 is directly connected, Serial0
S 10.10.90.0 [1/0] via 10.10.60.1
  • Lab Two: RIP

    As you could see in the fist lab, typing in all the routes manually is a bit of a nuisance, and trying to do this on a large or change-prone network could be a lot of work. You can use RIP to let the routers build and maintain dynamic routes.
    If you're doing these labs sequentially, you'll first need to log into each router and remove the static routes from global configuration mode. Here's how to do this for the HQ router:

    HQ(config)#no ip route 10.10.90.0 255.255.255.0 10.10.20.8
    HQ(config)#no ip route 10.10.40.0 255.255.255.0 10.10.60.8
    Do a wr t from the privileged mode # prompt to make certain these routes are removed.
    Now for each router, go into global configuration mode, turn on RIP, and advertise the relevant local interfaces. For HQ, this would be:

    HQ(config)#router rip
    HQ(config-router)# network 10.0.0.0
    If you do the same on both branch routers, then you can reach all the endpoints without manual intervention. You can run show IP Route to verify the operation and, of course, use Ping.
    Here's the route situation from Branch2 after we've removed the static routes and enabled RIP:

    Branch2#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1-IS-IS level-1, L2 - IS-IS level-2,*-candidate default
    U - per-user static route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 5 subnets
    R 10.10.20.0 [120/1] via 10.10.60.1, 00:00:15, Serial0
    C 10.10.40.0 is directly connected, Ethernet0
    R 10.10.50.0 [120/1] via 10.10.60.1, 00:00:15, Serial0
    C 10.10.60.0 is directly connected, Serial0
    R 10.10.90.0 [120/2] via 10.10.60.1, 00:00:15, Serial0
    Running ping, we can reach all of the networks from any other endpoint.

  • Lab Three: IGRP

    In Lammle's new CCNA book, he develops an IGRP lab by simply adding IGRP to the existing RIP configuration. This saves time and illustrates several points about IGRP.
    From global config mode, decide on an Autonomous System number (like 6), and enter that on each router, as we're doing on Branch2 below:

    Branch2(config)# router igrp 6
    Branch2(config-router)# network 10.10.0.0
    After enabling IGRP on all three routers, we can look at the IP routes from Branch2:

    Branch2#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
    U - per-user static route

    Gateway of last resort is not set

    	10.0.0.0/24 is subnetted, 5 subnets
    I 10.10.20.0 [100/10476] via 10.10.60.1, 00:00:26, Serial0
    C 10.10.40.0 is directly connected, Ethernet0
    I 10.10.50.0 [100/8576] via 10.10.60.1, 00:00:26, Serial0
    C 10.10.60.0 is directly connected, Serial0
    I 10.10.90.0 [100/10576] via 10.10.60.1, 00:00:26, Serial0

     

    Note that even though RIP is still running, the IGRP routes have a lower administrative distance than RIP and are preferred. For those planning to take the CCNA, make sure you have the complete administrative distance table in your notes, if not memorized.

  • Last Updated on Saturday, 22 October 2011 05:15