Working LCD - X700 Watchguard! - PFSense 2.0

Friday, 13 May 2011 22:14 Stephen10w
Print


stephen10w

 Working LCD on Watchguard X700 with PFSense 2.0!

-Steve-  http://www.pfsense.org/forum:
Edit: This only works correctly under 2.0. To use this file for 1.2.3 you need to add a sym link manually see
here.

Here's something that works!  Roll Eyes
At least it did with yesterdays build (pfSense-2.0-BETA5-1g-i386-20110209-1815) on a completely clean install.
Download the attachment to this message. Rename it lcdd4.tar (remove the .png).
Upload it to your firebox via Diagnostics\Command Prompt\Upload in the web interface. This will put the file in \tmp. Then open a command prompt via serial or shh and:
Code: (after you copy the file to the /tmp dir complete the commands in red)
[2.0-BETA5][root@pfSense.localdomain]/root(9): cd /tmp
[2.0-BETA5][root@pfSense.localdomain]/tmp(10): tar -xvf lcdd4.tar
x ./
x ./lcdd/
x ./install-embed2.lcdd.sh
x ./lcdd/drivers/
x ./lcdd/LCDd.conf
x ./lcdd/lcdd.sh
x ./lcdd/lcdproc
x ./lcdd/LCDd
x ./lcdd/drivers/curses.so
x ./lcdd/drivers/sdeclcd.so
[2.0-BETA5][root@pfSense.localdomain]/tmp(11): ./install-embed2.lcdd.sh
[2.0-BETA5][root@pfSense.localdomain]/tmp(12): /usr/local/etc/rc.d/lcdd.sh

And your lcd should be working.  Grin  

Changelog from lcdd3:
Reworked the install script to use rc.conf_mount_rw instead of 'mount -u -w /'.
Included the symlinking in the install script.
Changed the default lcd proc display options to C T U.
Changed the default LCDd.conf to use the front panel buttons correctly for menu access.  Smiley

Bugs:
(Xe box only) Having set it to use the buttons correctly I have found that the buttons on the Xe box are wired differently to the other fireboxes.  Angry When it starts you'll be left in the menu, just press the left button to escape. The result is no different to when the buttons weren't configured correctly.

Although I am using the rc.conf_mount_rw/ro commands in the script there is no need since it appears that (in this build at least) everything is mounted RW by default. Seems odd.

Steve

Download File Here...

-webadmin-   This setup works - No reboot even required if you run the syntax correctly... All credit goes to stephen10w - Thanks Steve!

Last Updated on Tuesday, 17 May 2011 22:16